All the applications from Apple Store are downloading and installing fine on my mac machine but when am trying to launch them am getting the error message saying that "Error: The application is not supported on this type of Mac." My mac machine is running on OS X 10.6.8.