When am trying to update my macbook pro which is currently running on mac os x 10.4.11 with mountain lion I get an dialogue box with a message you should have running 10.6.0 or later to install mountain lion. So tell me which method should I follow to upgrade to lion without this error.