Am trying to install the 'Mac OS X 10.6.8 Update Combo v1.1' update on my mac machine with os x Snow Leopard and am doing this from the Mac App Store, clicking on it doesn't starts installation process. I don't know what is required to install, but I see that this combo updater is compatible with all the earlier versions of Snow Leopard.