I have a Mac machine with the OS X 10.8.2, and also there are many applications installed on my machine till now. But recently when am trying to install new applications am getting a Warning with the text "You are running an unsupported version of the application.".